Support Center

Mailtrack isn't working (desktop version)

Last Updated: Nov 22, 2018 02:20PM CET

If the desktop version of Mailtrack isn't working then hopefully trying these steps will help:


Step 1: Reinstall the Mailtrack extension on your browser.

Instructions explaining how you can reinstall Mailtrack can be found here.

Step 2: Test in incognito mode.

Try using Mailtrack with your Gmail account in incognito mode/a new private window.

Please note that if you are using Chrome then you would first need to allow Mailtrack to work in incognito mode (instructions on how to do this can be found here).

If Mailtrack works in incognito mode/a private window but not in a normal browser window then there could be a caching issue or a possible conflict with another browser extension (browser extensions which can sometimes cause problems with Mailtrack include GhosteryVirtru, and uBlock origin), in which case you should try:

1) Clearing the browser cache (for details of how to do this in Chrome click here, for Firefox click here, and for Opera click here).
2) Testing by disabling any other browser extensions installed on your browser one-by-one, to see if this makes a difference when using Mailtrack in a normal browsing session. 

Step 3: Reset your browser to its default settings.

If you're unsure of how to do this then these FAQs can help:

Chrome: https://support.google.com/chrome/answer/3296214?hl=en
Firefox: https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems
Opera: https://help.opera.com/en/latest/crashes-and-issues/

If all of the above fail to solve your issue then there are a few other things you can try: 

-Restarting your computer. 
-Installing browser updates. 
-Logging out of any applications you're not currently using
-Connecting to the internet using ethernet instead of wifi.
-Reinstalling your browser.

Pro users can also contact our dedicated support team for help.

http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete